KMSAT - User Timeline & Smart Group Issues (US Only)
Incident Report for KnowBe4
Postmortem

On Friday, 7/15/2022, from approximately 5:00 a.m until 10:28 p.m. (ET), some users experienced issues with user timelines and Smart Groups in KMSAT.

This incident was caused by a backend database issue that prevented some events from being added to users' timelines. While deploying an update to resolve the issue, Smart Group functionality was also disrupted. Once the database was updated, KMSAT was able to return to normal performance by 10:28 p.m. (ET).

To prevent this type of issue in the future, we have made adjustments to the database.

No data loss occurred as a result of this issue.

Posted Aug 19, 2022 - 19:25 UTC

Resolved
This incident has been resolved.
Posted Jul 16, 2022 - 02:29 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 16, 2022 - 01:56 UTC
Identified
We've identified the cause of the user timeline and smart group issues and are working on implementing a fix. We'll continue to post on our status page with any new information or updates.
Posted Jul 15, 2022 - 17:31 UTC
This incident affected: Kevin Mitnick Security Awareness Training (KMSAT) (Console).