PhishER - PhishRIP Issues
Incident Report for KnowBe4
Postmortem

On Wednesday, 1/25/2023, from approximately 2:30 p.m. until 8:00 p.m. (ET), some PhishRIP queries were delayed.

This incident was caused by Microsoft 365 API delays that led to a backlog of PhishRIP requests. Once the API delays were resolved, PhishRIP was able to return to normal performance by 8:00 p.m. (ET).

To prevent this type of issue in the future, we are adding improvements to how we monitor and handle concurrent requests.

No data loss occurred as a result of this issue.

Posted Feb 01, 2023 - 21:31 UTC

Resolved
This incident has been resolved.
Posted Jan 26, 2023 - 16:41 UTC
Monitoring
A fix has been implemented for the issue with PhishRIP. We’re monitoring the results to make sure no further issues occur.
Posted Jan 26, 2023 - 02:59 UTC
Identified
We have received reports that users are experiencing issues with PhishRIP. We have identified the cause of this issue and will update this page when we have more information.
Posted Jan 25, 2023 - 21:46 UTC
This incident affected: PhishER (PhishRIP).