KMSAT - Console Loading Issues (US Only)
Incident Report for KnowBe4
Postmortem

On Thursday, 5/18/2023, from approximately 1:35 p.m. until 2:09 p.m. (UTC), some users experienced issues loading their KMSAT consoles.

This incident was caused by a database update that occurred while an application was still accessing queries from the database. As a result, the queries were backed up and some pages were unable to load. Once we stopped the queries and completed the database update, KMSAT was able to return to normal performance by 2:09 p.m. (UTC).

To prevent this type of issue in the future, we are adjusting our processes to better handle database updates during increased activity.

No data loss occurred as a result of this issue.

Posted May 24, 2023 - 11:07 UTC

Resolved
This incident has been resolved.
Posted May 18, 2023 - 14:46 UTC
Monitoring
We’ve implemented a fix for the issue causing users to experience loading issues with their KMSAT consoles. We’re monitoring the results to make sure no further issues occur.
Posted May 18, 2023 - 14:15 UTC
Investigating
We have received reports that some users are experiencing loading issues with their KMSAT consoles. We are investigating this issue and will update this page when we have more information.
Posted May 18, 2023 - 14:03 UTC
This incident affected: Kevin Mitnick Security Awareness Training (KMSAT) (Console).