KSAT - Training Video Issues
Incident Report for KnowBe4
Postmortem

On Monday, 07/08/2024, from approximately 8:50 a.m. until 12:05 p.m. (UTC), some users experienced issues in the US instance of the KSAT Learner Experience (LX). Videos did not play properly, and training sessions expired unexpectedly or did not record completion.
This incident was caused by a software component in one of our libraries that left behind unnecessary data over time, which led to our system's memory storage running out of space.
Once we updated the software component and removed unnecessary data, KSAT was able to return to normal performance by 12:05 p.m. (UTC).
To prevent this type of issue in the future, we increased the system’s memory storage space, upgraded the system after updating the software component, and set up regular cleanup tasks to remove old data.
During this incident, some training progress was not tracked. Users who were completing training may have needed to redo the training that was in progress during this incident.

Posted Jul 24, 2024 - 21:23 UTC

Resolved
This incident has been resolved.
Posted Jul 09, 2024 - 18:02 UTC
Investigating
We have received reports of videos not playing properly, sessions expiring, and training being closed out in the KSAT Learner Experience (LX). We are investigating this issue and will update this page when we have more information.
Posted Jul 09, 2024 - 12:57 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Learner Experience (LX)).