KCM GRC - US & EU SAML Login Issues
Incident Report for KnowBe4
Postmortem

On Friday, 4/22/2022, from approximately 8:28 a.m. until 1:11 p.m. (ET), some users were unable to log in to their KCM GRC consoles with single sign-on (SSO).

The incident was caused by a backend update that was meant to block an increase of malicious traffic. This update also prevented KCM GRC from successfully validating SSO attempts. Once the issue was identified and corrected, SSO for KCM GRC was able to return to normal performance by 1:11 p.m. (ET).

To prevent this issue in the future, we are adding improvements to our processes for monitoring the console and validating changes.

No data loss occurred as a result of this issue.

Posted Apr 27, 2022 - 19:23 UTC

Resolved
This incident has been resolved.
Posted Apr 22, 2022 - 17:14 UTC
Identified
We've identified the cause of the issue that some users in both the US and EU regions are experiencing when trying to log in with SAML and are working on implementing a fix. We'll continue to post on our status page with any new information or updates.
Posted Apr 22, 2022 - 15:56 UTC
Investigating
We have received reports that some users in both the US and EU regions are experiencing issues when trying to log in with SAML. We are investigating this issue and will update this page when we have more information.
Posted Apr 22, 2022 - 13:45 UTC
Identified
We've identified the cause of the issue that some users in both the US and EU regions are experiencing when trying to log in with SAML and are working on implementing a fix. We'll continue to post on our status page with any new information or updates.
Posted Apr 22, 2022 - 13:38 UTC
Investigating
We have received reports that some users in in both US and EU regions are experiencing issues when trying to log in with SAML. We are investigating this issue and will update this page when we have more information.
Posted Apr 22, 2022 - 13:31 UTC
This incident affected: KCM GRC (Console).