KMSAT - US, EU, & CA - User Profile Issues
Incident Report for KnowBe4
Postmortem

On Thursday, 3/17/2022, from approximately 12:31 p.m. until 5:47 p.m. (ET), some users experienced issues with user profiles not displaying in KMSAT.

This incident was caused by a code change that prevented user profiles from displaying if language settings weren’t set in the KMSAT database for the user. Once the code change was reverted, user profiles were able to return to normal performance by 5:47 p.m. (ET).

To prevent this type of issue in the future, we are adding additional testing and reviews to our workflow.

No data loss occurred as a result of this issue.

Posted Mar 25, 2022 - 15:13 UTC

Resolved
This incident has been resolved.
Posted Mar 17, 2022 - 21:47 UTC
Monitoring
We’ve implemented a fix for the issues some users were experiencing while trying to load the User Profile page and we’re monitoring the results to make sure no further issues occur.
Posted Mar 17, 2022 - 20:11 UTC
Identified
We've identified the cause of the issues some users are experiencing while trying to load the User Profile page and are working on implementing a fix. We'll continue to post on our status page with any new information or updates.
Posted Mar 17, 2022 - 18:05 UTC
Investigating
We have received reports that some users are experiencing issues loading the User Profile page. We are investigating this issue and will update this page when we have more information.
Posted Mar 17, 2022 - 16:31 UTC
This incident affected: Kevin Mitnick Security Awareness Training (KMSAT) (Console).