KMSAT - Audit Log Issues
Incident Report for KnowBe4
Postmortem

On Monday, 02/19/2024, from approximately 2:30 p.m. to Tuesday, 02/20/2024 at 10:30 a.m. (UTC), the KnowBe4 console did not send audit logs from one part of our system to another.

This incident was caused by a code change to our non-production environment that unexpectedly affected the production environment. Once we fixed the code, the KnowBe4 console was able to return to normal performance by 10:30 a.m. (UTC).

To prevent this type of issue in the future, we are improving our monitoring processes, adding more environment testing to our deployment processes, and adjusting our deployment schedule.

The data for the audit logs was not saved during the affected time period. All other system logs and records were unaffected.

Posted Feb 22, 2024 - 23:04 UTC

Resolved
This incident has been resolved.
Posted Feb 22, 2024 - 23:01 UTC
This incident affected: Kevin Mitnick Security Awareness Training (KMSAT) (Console).