KMSAT - Users, Phishing, & Training Issues (US only)
Incident Report for KnowBe4
Postmortem

On Wednesday, 2/1/2023, from approximately 7:00 a.m. until 10:00 a.m. (ET), some users experienced issues with the Users tab, phishing campaigns, and training campaigns in their KMSAT consoles.

This incident was caused by a recurring job that locked part of the database. As a result, other jobs were delayed, and database performance issues occurred. Once the lock was removed, KMSAT was able to return to normal performance by 10:00 a.m. (ET). While the remaining jobs were processed, phishing tests and training notifications were delayed up until 5:30 p.m. (ET).

To prevent this type of issue in the future, we will adjust our schedule for running recurring jobs.

No data loss occurred as a result of this issue.

Posted Feb 08, 2023 - 16:03 UTC

Resolved
The underlying issue for this incident has been resolved. Phishing emails and training notifications may be delayed while the backlog processes.
Posted Feb 01, 2023 - 18:26 UTC
Monitoring
We’ve implemented a fix for the issues with the Users tab, phishing campaigns, and training campaigns. We’re monitoring the results to make sure no further issues occur.
Posted Feb 01, 2023 - 15:11 UTC
Investigating
We have received reports that some users are experiencing issues with the Users tab, phishing campaigns, and training campaigns. We are investigating this issue and will update this page when we have more information.
Posted Feb 01, 2023 - 13:21 UTC
This incident affected: Kevin Mitnick Security Awareness Training (KMSAT) (Console, Phishing, Training).