KMSAT - Smart Group Issues
Incident Report for KnowBe4
Postmortem

On Wednesday, 12/7/2022, from approximately 9:00 p.m. (ET) until Friday, 12/9/2022, at 9:00 a.m. (ET), some users experienced issues with Smart Groups.

This incident was caused by a backend system upgrade that led to users being removed from Smart Groups when they should not have been. As a result, the users were re-enrolled in campaigns, and events were added to the users’ timelines. Once the issue was resolved, KMSAT was able to return to normal performance by Friday, 12/9/2022, at 9:00 a.m. (ET). The campaign re-enrollments and timeline events for the affected users were also corrected.

To prevent this type of issue in the future, an issue where backend errors would appear as successful has been patched.

No data loss occurred as a result of the issue.

Posted Dec 28, 2022 - 15:42 UTC

Resolved
This incident has been resolved.
Posted Dec 14, 2022 - 16:25 UTC
Identified
We've identified the cause of the issue where some users are experiencing issues with their Smart Groups. We are working on implementing a fix. We'll continue to post on our status page with any new information or updates.
Posted Dec 12, 2022 - 14:15 UTC
Investigating
We have received reports that some users are experiencing issues with their Smart Groups. We are investigating this issue and will update this page when we have more information.
Posted Dec 09, 2022 - 18:16 UTC
This incident affected: Kevin Mitnick Security Awareness Training (KMSAT) (Console).