KMSAT - Download Center Issues (US Only)
Incident Report for KnowBe4
Postmortem

On Monday, 04/15/2024, from approximately 6:30 p.m. until 10:00 p.m. (UTC), some users experienced issues with generating reports in the KSAT Download Center.

This incident was caused by multiple requests for reports containing large amounts of data, which backed up the report generation queue. Once we increased the resources available to the system to process the reports, the Download Center was able to return to normal performance by 10:00 p.m. (UTC).

To prevent this type of issue in the future, we have implemented improvements to allow the system to simultaneously process large reports.

No data loss occurred as a result of this issue.

Posted May 06, 2024 - 16:43 UTC

Resolved
This incident has been resolved.
Posted Apr 19, 2024 - 12:40 UTC
Monitoring
We’ve implemented a fix for the report downloading issue and we’re monitoring the results to make sure no further issues occur.
Posted Apr 16, 2024 - 14:39 UTC
Identified
We've identified the cause of the report downloading issue and are working on implementing a fix. We'll continue to post on our status page with any new information or updates.
Posted Apr 15, 2024 - 21:01 UTC
Investigating
We have received reports that some admins are experiencing issues with downloading reports as CSV files. We are investigating this issue and will update this page when we have more information.
Posted Apr 15, 2024 - 19:47 UTC
This incident affected: Kevin Mitnick Security Awareness Training (KMSAT) (Reporting).