A fix has been implemented and we are monitoring the results.
Posted Sep 24, 2026 - 21:46 UTC
Investigating
We have identified an issue with Protect & Prevent that has resulted in degraded performance, and our engineering team is looking into a fix.
Posted Sep 24, 2026 - 19:57 UTC
Monitoring
We have identified an issue with Protect that has resulted in degraded performance. A fix has been implemented, and we will continue to monitor this issue.
Posted Sep 24, 2026 - 18:39 UTC
Investigating
We have identified an issue with Protect that has resulted in degraded performance, and our engineering team is looking into a fix.
Posted Sep 24, 2026 - 17:53 UTC
This incident affects: Prevent (Mail Flow) and Protect (Mail Flow).