KMSAT - ADI and SCIM Syncs in Pending Status

Incident Report for KnowBe4

Postmortem

On Tuesday, 12/5/2023, from approximately 7:30 p.m. (UTC) to Wednesday, 12/6/2023, at 2:30 p.m. (UTC), some users experienced delays when provisioning users in KMSAT.

This incident was caused by an incorrectly configured file that was deployed during an update to our user provisioning service. Due to this issue, some KMSAT accounts were unable to sync with their identity providers. Once a fix for the file was deployed, all syncs resumed as previously scheduled, and KMSAT was able to return to normal performance by 2:30 p.m. (UTC).

To prevent this type of issue in the future, we are improving our monitoring processes to ensure that the user provisioning service remains available.

No data loss occurred as a result of this issue.

Posted Dec 11, 2023 - 18:35 UTC

Resolved

This incident has been resolved.
Posted Dec 06, 2023 - 17:14 UTC

Monitoring

We’ve implemented a fix for the user provisioning issue, and we’re monitoring the results to make sure no further issues occur.
Posted Dec 06, 2023 - 14:13 UTC

Investigating

We have received reports that ADI and SCIM user provisioning syncs have been pending for an extended time on certain KMSAT accounts. We are actively investigating this issue and will update this page with more information when we have it.
Posted Dec 06, 2023 - 13:24 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (User Provisioning).