KSAT Latency Issues

Incident Report for KnowBe4

Resolved

Our team has identified and resolved the issue causing latency with the KSAT console
Posted May 18, 2026 - 21:40 UTC

Monitoring

Our team has identified an issue causing latency with the KSAT console. A fix has been implemented and we will continue to monitor.
Posted May 18, 2026 - 17:28 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Console).