PhishER - US PhishRIP Issues
Incident Report for KnowBe4
Postmortem

On Monday, 4/25/2022, from approximately 3:00 p.m. (ET) until Tuesday, 4/26/2022 at 1:54 p.m. (ET), some users experienced issues with PhishRIP queries not completing in a timely manner.

This incident was caused by a backend update that added a new field for PhishRIP queries. The update set a default value for the new field to ensure future PhishRIP queries were successful. However, PhishRIP queries that were in progress when the update was deployed did not have a value for the new field, causing these queries to fail. Once a value was set in the new field for PhishRIP queries in progress, PhishRIP was able to return to normal performance by Tuesday, 4/26/2022 at 1:54 p.m. ET.

To prevent this issue in the future, we will improve our testing to ensure updates do not cause preexisting PhishRIP queries to fail.

No data loss occurred as a result of this issue.

Posted May 06, 2022 - 14:23 UTC

Resolved
This incident has been resolved.
Posted Apr 26, 2022 - 20:11 UTC
Monitoring
We’ve implemented a fix for the issues with PhishRIP queries. We’re monitoring the results to make sure no further issues occur.
Posted Apr 26, 2022 - 18:48 UTC
Identified
We've identified the cause of the issues with PhishRIP queries and are working on implementing a fix. We'll continue to post on our status page with any new information or updates.
Posted Apr 26, 2022 - 16:38 UTC
Investigating
We have received reports that some users are experiencing issues with PhishRIP queries. We are investigating this issue and will update this page when we have more information.
Posted Apr 26, 2022 - 15:38 UTC
This incident affected: PhishER (PhishRIP).