We are continuing to monitor for any further issues.
Posted Oct 09, 2025 - 12:37 UTC
Monitoring
We have seen improvements with Azure's "Front Door" service and we are monitoring the results to make sure no further issues occur.
Posted Oct 09, 2025 - 12:32 UTC
Identified
We’ve identified the issue as being related to Azure "Front Door" service outages in multiple regions. Our team is in active contact with Microsoft and working to mitigate the impact. We’ll continue to share updates here as more information becomes available.
Posted Oct 09, 2025 - 10:52 UTC
Update
We are continuing to investigate this issue.
Posted Oct 09, 2025 - 09:23 UTC
Update
We are continuing to investigate this issue.
Posted Oct 09, 2025 - 09:19 UTC
Investigating
We are currently investigating this issue.
Posted Oct 09, 2025 - 09:18 UTC
This incident affected: Prevent (Console, Mail Flow, Authentication, Web Add-In), Protect (Console, Mail Flow, Authentication, Web Add-In, Web Access), Defend (Console), and KnowBe4 Security Center, Secure Web Forms.