Prevent and Protect - Administration Panel Slow or Inaccessible

Incident Report for KnowBe4

Resolved

This incident has been resolved.
Posted Mar 20, 2026 - 12:18 UTC

Monitoring

We’ve implemented a fix and we’re monitoring the results to make sure no further issues occur.
Posted Mar 19, 2026 - 13:48 UTC

Investigating

We have received reports that access to the KnowBe4 Administration Panel is slow or inaccessible. We are investigating this issue and will update this page when we have more information.
Posted Mar 19, 2026 - 12:33 UTC
This incident affected: Prevent (Web Add-In) and Protect (Web Add-In, Web Access).