PhishER - Page Loading Issues (US Only)

Incident Report for KnowBe4

Postmortem

On Tuesday, July 21, 2025, from approximately 6:45 p.m. to Wednesday, July 22, 2025, at approximately 2:30 a.m. (UTC), some US customers experienced slow loading times and access issues with the PhishER console.

These issues were caused by an update to the PhishER console. This update required customers to reauthenticate while logging in to PhishER, but it caused unexpected error handling for failed authentication attempts. To resolve this issue, we reverted the update, and the PhishER console loading times returned to normal performance by July 22 at approximately 2:30 a.m. (UTC).

To prevent this type of issue in the future, we have improved error handling for when authentication requests fail and our deployment workflow for similar future updates.

No data loss occurred as a result of this issue.

Posted Jul 29, 2025 - 17:53 UTC

Resolved

This incident has been resolved.
Posted Jul 22, 2025 - 22:01 UTC

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Jul 22, 2025 - 02:54 UTC

Identified

We have identified an issue where some users might experience periods of inaccessibility to the PhishER console. We are continuing to work on a resolution for this issue.
Posted Jul 22, 2025 - 01:00 UTC

Investigating

We have received reports that users are experiencing errors when accessing the PhishER console. We are investigating this issue and will update this page when we have more information.
Posted Jul 21, 2025 - 18:53 UTC
This incident affected: PhishER (Console).