PAB Operation Timeout

Incident Report for KnowBe4

Postmortem

On Monday, May 12, 2025, from approximately 3:58 p.m. to Tuesday, May 13, 2025, at 1:41 p.m. (UTC), some customers experienced errors when using the Microsoft Ribbon Phish Alert Button (PAB).

These issues were caused by an update to resolve API token compatibility issues for the Microsoft Ribbon PAB and the Hybrid PAB. This update improved how tokens are handled, but it also caused Microsoft Ribbon PAB errors for certain classic Microsoft Outlook environments with legacy Microsoft Exchange tokens blocked. To resolve this issue, we updated our code to account for the blocked legacy tokens, and the Microsoft Ribbon PAB returned to normal performance by May 13, 2025, at 1:41 p.m. (UTC).

To prevent this type of issue in the future, we have improved our testing workflow by adding more Microsoft Outlook version testing for Microsoft Ribbon PAB updates. We have also further improved our update processes to account for environmental variations specific to the Microsoft Ribbon PAB. Lastly, we have also updated the Prerequisites section of our Microsoft Ribbon Phish Alert Button (PAB) Product Manual to notify of potential compatibility issues when using classic Microsoft Outlook with the Microsoft Ribbon PAB.

No data loss occurred as a result of this issue.

Posted May 19, 2025 - 14:44 UTC

Resolved

This incident has been resolved.
Posted May 13, 2025 - 15:16 UTC

Investigating

We are currently investigating this issue.
Posted May 13, 2025 - 10:29 UTC
This incident affected: Phish Alert Button.