KSAT - Pages not loading

Incident Report for KnowBe4

Resolved

This incident has been resolved.
Posted Apr 30, 2025 - 21:03 UTC

Monitoring

We have received reports that Pages are not loading. We are investigating this issue and will update this page when we have more information.
Posted Apr 30, 2025 - 19:52 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Console).