KMSAT - SAML, Passwordless Login, and Password Reset Issues
Incident Report for KnowBe4
Postmortem

On Thursday, 05/04/2023, from approximately 5:55 p.m. until 6:17 p.m. (UTC), some users were unable to log in to their KMSAT consoles using SAML or passwordless login. Additionally, some users were unable to access the Account Information page or reset their passwords.

This incident was caused by a backend update that removed code used by another backend process. Once the update finished deploying, KMSAT was able to return to normal performance by 6:17 p.m. (UTC).

To prevent this type of issue in the future, we are improving our internal processes for removing code. 

No data loss occurred as a result of this issue.

Posted May 05, 2023 - 16:04 EDT

Resolved
This incident has been resolved.
Posted May 04, 2023 - 16:46 EDT
Monitoring
We’ve implemented a fix for the SAML and passwordless login issues. This fix is also for an issue with password resets. We’re monitoring the results to make sure no further issues occur.
Posted May 04, 2023 - 14:36 EDT
Investigating
We have received reports that some users are experiencing issues when trying to log in with SAML or with passwordless login. We are investigating this issue and will update this page when we have more information.
Posted May 04, 2023 - 13:54 EDT
This incident affected: Kevin Mitnick Security Awareness Training (KMSAT) (Console).