A fix has been implemented and we are monitoring the results.
Posted Jul 09, 2025 - 16:10 UTC
Investigating
We have received reports that Phishing and Training campaigns are not starting. We are investigating this issue and will update this page when we have more information.
Posted Jul 09, 2025 - 13:24 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 07, 2025 - 19:05 UTC
Investigating
We have received reports that Phishing Campaigns and Training Notifications are delayed on our US server. We are investigating this issue and will update this page when we have more information.
Posted Jul 07, 2025 - 16:49 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Phishing, Training, Email Delivery).