KMSAT - Phishing Campaign Issues
Incident Report for KnowBe4
Postmortem

On Friday, 2/17/2023, from approximately 12:30 p.m. (ET), until Monday, 2/20/23, at 4:00 p.m. (ET), some users experienced issues with their phishing campaigns closing early.

This incident was caused by a code change that led to phishing campaigns being created with shortened durations. These shortened durations caused some phishing campaigns to close early, which prevented further phishing failures from being tracked. Once a fix for this code was tested and deployed, KMSAT was able to return to normal performance by Monday, 2/20/23, at 4:00 p.m. (ET). We corrected the durations of open campaigns that were affected by this incident, but we were unable to correct any affected campaigns that were closed before the fix was deployed.

To prevent this type of issue in the future, we are making adjustments to our testing to ensure campaign durations are created correctly.

No data loss occurred as a result of this issue.

Posted Feb 27, 2023 - 16:56 UTC

Resolved
This incident has been resolved.
Posted Feb 21, 2023 - 14:26 UTC
Monitoring
We’ve implemented a fix for the phishing campaign issues and we’re monitoring the results to make sure no further issues occur.
Posted Feb 20, 2023 - 21:44 UTC
Identified
We've identified the cause of the issues some users are experiencing with their phishing campaigns and are working on implementing a fix. We'll continue to post on our status page with any new information or updates.
Posted Feb 20, 2023 - 15:54 UTC
Update
We have received reports that users are experiencing issues related to phishing campaigns. We are continuing to investigate this issue and will update this page when we have more information.
Posted Feb 20, 2023 - 14:48 UTC
Investigating
We have received reports that users are experiencing issues related to phishing campaign tracking durations. We are investigating this issue and will update this page when we have more information.
Posted Feb 20, 2023 - 13:29 UTC
This incident affected: Kevin Mitnick Security Awareness Training (KMSAT) (Phishing).