We've identified an issue that resulted in a Restricted error when attempting to access the PhishER console for UK and CA customers. Our team has implemented a fix and this has now been resolved.
Posted Apr 20, 2026 - 18:50 UTC
Identified
We've identified an issue that is resulting in a Restricted error when attempting to access the PhishER console for UK and CA customers, and we are working on implementing a resolution.
Posted Apr 20, 2026 - 15:53 UTC
Monitoring
We've identified the issue that was resulting in a Restricted error when attempting to access the PhishER console for UK and CA customers and have implemented a fix. Impacted users may need to refresh the page to access the PhishER console.