KSAT Login Issues

Incident Report for KnowBe4

Postmortem

On Wednesday, March 19, 2025, from approximately 3:18 p.m. to 4:02 p.m. (UTC), some customers experienced errors while using the KSAT console.

This issue was caused by a prior code version update that was deployed. The new code version was incompatible with a related application, and this caused SAML login errors for some customers. To resolve this issue, we reverted the update, and the KSAT console returned to normal performance by 4:02 p.m. (UTC).

To prevent this type of issue in the future, we have implemented additional testing workflows for similar updates, including additional testing for application compatibility.

No data loss occurred as a result of this issue.

Posted Apr 04, 2025 - 21:08 UTC

Resolved

This incident has been resolved.
Posted Mar 19, 2025 - 18:45 UTC

Monitoring

We have deployed a fix for these issues and will monitor for any ongoing problems.
Posted Mar 19, 2025 - 16:09 UTC

Identified

We've received reports that some KSAT customers are unable to log in to their consoles and are receiving 500 errors. We are investigating and will update this page when we have more information.
Posted Mar 19, 2025 - 15:30 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Console).