KSAT - Loading Issues (US Only)
Incident Report for KnowBe4
Postmortem

On Wednesday, October 16th, 2024, from approximately 8:36 a.m. to 2:30 p.m. (UTC), some customers experienced login issues with the KSAT console and loading issues with the Modstore.

These issues were caused by an earlier incident from October 15th, 2024: KSAT - Increased Error Rates (US Only). The earlier incident cause was identified and a fix was developed, but these secondary issues occurred before the fix was fully deployed. Upon releasing the fix, the KSAT console and the ModStore returned to normal performance by October 16th, 2024 at 2:30 p.m. (UTC).

To prevent this type of issue in the future, we have updated our engineering procedures to prioritize the deployment of fixes of this type.

No data loss occurred as a result of this issue.

Posted Oct 23, 2024 - 21:31 UTC

Resolved
This incident has been resolved.
Posted Oct 16, 2024 - 20:06 UTC
Monitoring
We’ve implemented a fix for the KSAT console loading issues and we’re monitoring the results to make sure no further issues occur.
Posted Oct 16, 2024 - 14:42 UTC
Update
We have received reports that customers are experiencing latency and loading errors in the KSAT console. We are continuing to investigate this issue and will update this page when we have more information.
Posted Oct 16, 2024 - 14:18 UTC
Investigating
We have received reports that some customers are experiencing loading errors in the KSAT Modstore. We are investigating this issue and will update this page when we have more information.
Posted Oct 16, 2024 - 13:41 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Console, ModStore).