KSAT - User Details Errors (EU and US Only)
Incident Report for KnowBe4
Postmortem

On Wednesday, December 4, 2024, from approximately 6:26 p.m. to 8:45 p.m. (UTC), some customers experienced errors when accessing user details for EU and US instances of the KSAT console.

These issues were caused by an update to the KSAT console. Certain database schema were not aligned during this update, causing user Risk Scores to return empty values and generate errors when accessing user details. To resolve these issues, we reverted the update, and the KSAT console returned to normal performance by 8:45 p.m. (UTC).

To prevent this type of issue in the future, we are researching the use of additional testing methods when deploying similar updates.

No data loss occurred as a result of this issue

Posted Jan 28, 2025 - 20:55 UTC

Resolved
This incident has been resolved.
Posted Dec 04, 2024 - 21:04 UTC
Monitoring
We’ve implemented a fix for the user details errors in the KSAT console and we’re monitoring the results to make sure no further issues occur.
Posted Dec 04, 2024 - 19:42 UTC
Investigating
We have received reports that admins are experiencing errors when accessing the User Details page in the KSAT console. We are investigating this issue and will update this page when we have more information.
Posted Dec 04, 2024 - 18:46 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Console).