KSAT Login Issues (US)

Incident Report for KnowBe4

Postmortem

On Thursday, June 26, 2025, from approximately 3:50 p.m. to approximately 9:40 p.m. (UTC), some US customers experienced errors when trying to log in to the KSAT console.

These issues were caused by an earlier update that aimed to improve processing speeds for user syncing. This update did not cause any issues until June 26, when high user sync traffic caused a temporary console slowdown and login errors. The issues were resolved automatically as the sync jobs were completed and traffic returned to normal levels. The KSAT console returned to normal performance by 9:40 p.m. (UTC).

To prevent this type of issue in the future, we have updated our code to sync users in batches during periods of unusually high traffic.

No data loss occurred as a result of this issue.

Posted Aug 05, 2025 - 19:30 UTC

Resolved

This incident has been resolved.
Posted Jun 27, 2025 - 19:52 UTC

Monitoring

A fix for this issue has been implemented, and we are monitoring the results.
Posted Jun 26, 2025 - 23:29 UTC

Investigating

We've received reports that some KSAT customers are unable to log in to their consoles and are receiving 500 errors. We are investigating and will update this page when we have more information.
Posted Jun 26, 2025 - 16:01 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Console).