KMSAT - Issues with Creating or Editing Campaigns
Incident Report for KnowBe4
Postmortem

On Tuesday, 03/12/2024, from approximately 10:00 p.m. (UTC) until Wednesday, 03/13/2024 at 1:30 a.m. (UTC), some users experienced issues with managing phishing campaigns in their KnowBe4 console.

This incident was caused when some pages in the KnowBe4 console, including Profile, Users, Account Settings, Training Campaigns, and Phishing Campaigns, did not automatically adjust the time zones for daylight saving time. Once we adjusted the time zones, the KnowBe4 console was able to return to normal performance by Wednesday at 1:30 a.m. (UTC).

To prevent this type of issue in the future, we plan to add more testing to our workflows.

No data loss occurred as a result of this issue.

Posted Mar 25, 2024 - 17:30 UTC

Resolved
This incident has been resolved.
Posted Mar 13, 2024 - 19:45 UTC
Monitoring
A fix has been implemented and we are monitoring the results to ensure no further issues occur.
Posted Mar 13, 2024 - 13:47 UTC
Investigating
We have received reports that some users are having issues creating, editing, or cloning training and phishing campaigns. We are investigating this issue and will update this page when we have more information.
Posted Mar 12, 2024 - 19:15 UTC
This incident affected: Kevin Mitnick Security Awareness Training (KMSAT) (Phishing, Training).