Important Note: We recently updated one of our IPs to optimize email deliverability for our Security Awareness Training (KMSAT) and PhishER platforms.

If you're using Office 365 and you've already whitelisted KnowBe4's IPs but are experiencing email deferments or delays, we recommend setting up a receive connector according to the instructions in this article.

KCM GRC - Issues with Metrics Page
Incident Report for KnowBe4
Postmortem

From approximately 2:35 p.m. (ET) to 7:40 p.m. (ET), some users received an error when trying to load the KCM Metrics page while other users were experiencing issues with the console unexpectedly shutting down when trying to load a detailed report.

These issues were caused by a large number of queries to the database, a large quantity of data being returned, and an incorrectly configured cache query that took too long to run.

To prevent this issue in the future, we will continue monitoring the database for any abnormal querying and will ensure that queries do not request more data than the application is capable of processing. No data loss occurred as a result of this issue.

Posted Aug 03, 2020 - 17:21 EDT

Resolved
This issue has been resolved.
Posted Jul 31, 2020 - 14:38 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 30, 2020 - 19:40 EDT
Investigating
We are currently investigating an issue with the Metrics page that is causing performance issues in the KCM platform.
Posted Jul 30, 2020 - 19:35 EDT
This incident affected: KCM.