Protect - Intermittent Issues with Sending Emails (UK Only)

Incident Report for KnowBe4

Resolved

This incident has been resolved.
Posted May 27, 2026 - 15:44 UTC

Monitoring

We’ve implemented a fix and we’re monitoring the results to make sure no further issues occur.
Posted May 27, 2026 - 14:39 UTC

Investigating

We have received reports that there is a Intermittent issue sending emails for Protect. We are investigating this issue and will update this page when we have more information.
Posted May 27, 2026 - 10:05 UTC
This incident affected: Protect (Mail Flow).