KSAT - Account Settings Issues
Incident Report for KnowBe4
Postmortem

On Thursday, August 22nd, 2024, from approximately 3 p.m until 4:30 p.m (UTC), some users experienced issues when saving changes to the Account Settings in their KnowBe4 console. 

This incident was caused when we deployed a code change for standardizing date formats in our CSV reports. The code change was deployed under a feature flag, and included a misconfiguration that unexpectedly affected accounts that had the feature flag enabled. Once we reverted the code change, the KnowBe4 console was able to return to normal performance by 4:30 p.m. (UTC).

To prevent this type of issue in the future, we added more tests to this workflow.

No data loss occurred as a result of this issue.

Posted Aug 28, 2024 - 16:08 UTC

Resolved
This incident has been resolved.
Posted Aug 22, 2024 - 18:14 UTC
Monitoring
We’ve implemented a fix for the issue with saving Account Settings in the KSAT console. and we’re monitoring the results to make sure no further issues occur.
Posted Aug 22, 2024 - 16:32 UTC
Investigating
We have received reports that some customers are unable to save Account Settings in the KSAT console. We are investigating this issue and will update this page when we have more information.
Posted Aug 22, 2024 - 15:16 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Account Settings).