KMSAT - Console Loading Issues
Incident Report for KnowBe4
Postmortem

On Friday, 2/3/2023, from approximately 7:00 a.m. until 1:00 p.m. (ET), some users experienced issues loading the ModStore tab, training campaigns, and the User Details page.

This incident was caused by a code change that increased activity in the ModStore database, preventing some pages from loading successfully. Once the code change was reverted, KMSAT was able to return to normal performance by 1:00 p.m. (ET).

To prevent this type of issue in the future, we are adjusting our process for similar code changes. We are also upgrading the ModStore database to handle increased activity.

No data loss occurred as a result of this issue.

Posted Feb 15, 2023 - 20:04 UTC

Resolved
This incident has been resolved.
Posted Feb 03, 2023 - 19:15 UTC
Monitoring
We’ve implemented a fix for the loading issues some users are experiencing with the ModStore tab, training campaigns, and the User Details page. We’re monitoring the results to make sure no further issues occur.
Posted Feb 03, 2023 - 18:18 UTC
Identified
We've identified the cause of the loading issues some users are experiencing with the ModStore tab, training campaigns, and the User Details page and are working on implementing a fix. We'll continue to post on our status page with any new information or updates.
Posted Feb 03, 2023 - 16:34 UTC
Update
We have received reports that some users are experiencing loading issues with the ModStore tab, training campaigns, and the User Details page. We are continuing to investigate this issue and will update this page when we have more information.
Posted Feb 03, 2023 - 16:04 UTC
Investigating
We have received reports that some users are experiencing loading issues with their KMSAT consoles. We are investigating this issue and will update this page when we have more information.
Posted Feb 03, 2023 - 15:21 UTC
This incident affected: Kevin Mitnick Security Awareness Training (KMSAT) (Console).