KSAT - Account Settings Issues
Incident Report for KnowBe4
Postmortem

On Thursday, August 16, 2024, from approximately 3:17 p.m. to 3:45 p.m. (UTC), some customers were unable to access their Account Settings in the KnowBe4 console.

This incident was caused by a configuration change to a backend database. During the update, two fields with a null value caused errors when they were searched for. Another update was deployed to account for the null values and the console returned to regular performance by 3:45 p.m.

No data loss occurred as a result of this issue.

Posted Sep 06, 2024 - 14:44 UTC

Resolved
This incident has been resolved.
Posted Aug 16, 2024 - 17:10 UTC
Monitoring
We’ve implemented a fix for the issue with the KSAT account settings and we’re monitoring the results to make sure no further issues occur.
Posted Aug 16, 2024 - 15:53 UTC
Identified
We have identified an issue with KSAT account settings not loading and we are working on implementing a fix. We'll update our status page with any new information or updates.
Posted Aug 16, 2024 - 15:27 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Console).