Webforms | Partial Submission Issue (UK only)

Incident Report for KnowBe4

Resolved

This incident has been successfully resolved and all systems are fully operational.
Posted Sep 23, 2026 - 14:58 UTC

Monitoring

The issue has been identified and a fix has been implemented and will update this page when we have more information.
Posted Sep 23, 2026 - 10:58 UTC

Identified

The issue has been identified and a fix is been implemented. An update with more information will follow accordingly.
Posted Sep 23, 2026 - 10:47 UTC

Investigating

We have received reports that some users are unable to successfully submit webform submissions. We are investigating this issue and will update this page when we have more information.
Posted Sep 23, 2026 - 09:00 UTC
This incident affected: Secure Web Forms.