KMSAT - Issues Loading Account Settings
Incident Report for KnowBe4
Postmortem

On Tuesday, 11/14/2023, from approximately 1:30 p.m. to 3:30 p.m. (UTC), some users experienced issues loading their KMSAT Account Settings page.

This incident was caused by a backend update that deployed on Monday, 11/13/2023, at 3:47 p.m. (UTC) and unexpectedly affected the frontend of some KMSAT accounts. Once the issue was resolved, KMSAT was able to return to normal performance by 3:30 p.m. (UTC).

To prevent this type of issue in the future, we are making adjustments to our updating processes.

No data loss occurred as a result of this issue.

Posted Nov 20, 2023 - 20:49 UTC

Resolved
This incident has been resolved.
Posted Nov 14, 2023 - 18:49 UTC
Monitoring
We’ve implemented a fix for the issues some users were experiencing with their account settings and we’re monitoring the results to make sure no further issues occur.
Posted Nov 14, 2023 - 16:03 UTC
Investigating
We have received reports that some users are experiencing issues loading their Account Settings page. We are investigating this issue and will update this page when we have more information.
Posted Nov 14, 2023 - 14:09 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Console).