KSAT - Phishing Campaign and Training Campaign Issues (US Only)
Incident Report for KnowBe4
Postmortem

On Tuesday, October 1, 2024, from approximately 12:00 p.m. until 10:00 p.m. (UTC), some users experienced issues with phishing and training campaigns not starting as expected, training modules not being marked as complete, and some reports not downloading on the US instance of their KSAT console.

This incident was caused when a system update to improve user enrollments did not update our scaling system and caused our queues to become backed up.

To resolve this issue, we adjusted the system settings to allow the console to scale for increased traffic.
Once the settings were adjusted, KSAT was able to return to normal performance by 10:00 p.m. (UTC).

To prevent this type of issue in the future, we updated the default settings in our code to prevent similar slowdowns. We also implemented additional monitoring for the scaling system.

No data loss occurred as a result of this issue.

Posted Oct 15, 2024 - 16:03 UTC

Resolved
This incident has been resolved.
Posted Oct 02, 2024 - 15:36 UTC
Monitoring
We’ve implemented a fix for the issues and we’re monitoring the results to make sure no further issues occur.
Posted Oct 01, 2024 - 20:23 UTC
Identified
We've identified the cause of the issues related to phishing campaigns, training campaigns, and training modules. We’re working on implementing a fix and we'll continue to post on our status page with any new information or updates.
Posted Oct 01, 2024 - 16:46 UTC
Investigating
We have received reports that phishing and training campaigns are not starting as expected, and training modules are not being marked as complete. We are investigating this issue and will update this page when we have more information.
Posted Oct 01, 2024 - 15:48 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Phishing, Training, Learner Experience (LX)).