KSAT - Learner Experience Issues (US Only)
Incident Report for KnowBe4
Postmortem

On Monday, December 2, 2024, from approximately 1:15 p.m. until 3:28 p.m. (UTC), some users experienced issues with loading the Learner Experience (LX) on the US instance of the KSAT console.

This incident was caused when we deployed an update to improve the LX’s efficiency in loading recommended training modules. The update gradually caused an overload on our server’s CPU due to inefficient backend processes.

To resolve this issue, the update was reverted and the KSAT console returned to normal performance by 3.28 p.m. (UTC).

To prevent this type of issue in the future, we are adding improvements to the scaling, monitoring, and alert systems for the LX before we redeploy the update.

No data loss occurred as a result of this issue.

Posted Dec 10, 2024 - 21:41 UTC

Resolved
This incident has been resolved.
Posted Dec 02, 2024 - 21:53 UTC
Monitoring
We’ve implemented a fix for the loading issue with the KSAT Learner Experience and we’re monitoring the results to make sure no further issues occur.
Posted Dec 02, 2024 - 16:40 UTC
Investigating
We have received reports that the KSAT Learner Experience is not loading. We are investigating this issue and will update this page when we have more information.
Posted Dec 02, 2024 - 15:10 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Learner Experience (LX)).