Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 26, 2023 - 01:00 UTC
Scheduled
We will be performing maintenance on the US instance of KMSAT and PhishER on October 26th, 2023 from 1 - 1:30 a.m. (UTC).
For approximately 10 minutes during this maintenance period, features related to email delivery and Email Exposure Check Pro (EECPro) will be unavailable.
Posted Oct 24, 2023 - 19:51 UTC
This scheduled maintenance affected: PhishER (Notification Service) and Kevin Mitnick Security Awareness Training (KMSAT) (Email Delivery).