KSAT - Saved Reports Tab Not Loading

Incident Report for KnowBe4

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 12:49 UTC

Monitoring

We’ve implemented a fix for the Saved Reports tab and we’re monitoring the results to make sure no further issues occur.
Posted Dec 04, 2025 - 20:58 UTC

Identified

We've identified why the Saved Reports tab is not loading and are working on implementing a fix. We'll continue to post on our status page with any new information or updates.
Posted Dec 04, 2025 - 17:04 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Reporting).