KMSAT - Training Campaign Notification Issues
Incident Report for KnowBe4
Resolved
This incident has been resolved.
Posted Mar 26, 2024 - 20:41 UTC
Monitoring
We’ve implemented a fix for the issue with notifications for archived users. We’re monitoring the results to make sure no further issues occur.
Posted Mar 25, 2024 - 20:23 UTC
Investigating
We have received reports that some users are receiving notifications for archived users on the US instance of their KnowBe4 console. We are investigating this issue and will update this page when we have more information.
Posted Mar 25, 2024 - 17:11 UTC
This incident affected: Kevin Mitnick Security Awareness Training (KMSAT) (Training).