PhishER - Slow Loading Issues
Incident Report for KnowBe4
Postmortem

On Friday, 06/07/2024, from approximately 5:23 p.m. until Monday, 06/10/2024 at 7:00 p.m. (UTC), some users experienced slow loading times in the US instance of their PhishER platform.
This incident was caused by an internal service that called an incorrect endpoint on the PhishER API, which resulted in long-running queries to the database and slowness on the PhishER platform. The incident was resolved when the internal service completed its tasks, and PhishER was able to return to normal performance by Friday, 06/07/2024, at 7:30 p.m. (UTC).
To prevent this type of issue in the future, we updated the internal service on Monday, 06/10/2024 at 7:00 p.m. (UTC). The update prevents the internal service from calling the wrong endpoint with additional data validation.
No data loss occurred as a result of this issue.

Posted Jun 13, 2024 - 21:24 UTC

Resolved
This incident has been resolved.
Posted Jun 11, 2024 - 21:04 UTC
Monitoring
We’ve implemented a fix for the slow loading times for PhishER and we’re monitoring the results to make sure no further issues occur.
Posted Jun 07, 2024 - 19:39 UTC
Investigating
We have received reports from some users about slow loading times for PhishER. We are looking into this issue and will update this page when we have more information.
Posted Jun 07, 2024 - 17:23 UTC
This incident affected: PhishER (Console).