KMSAT - US, EU, & CA - Account Settings Issues

Incident Report for KnowBe4

Resolved

This incident has been resolved.
Posted Dec 06, 2021 - 21:22 UTC

Monitoring

We’ve implemented a fix for the Account Settings issues and we’re monitoring the results to make sure no further issues occur.
Posted Dec 06, 2021 - 19:06 UTC

Identified

We've identified the cause of the Account Settings issues and are working on implementing a fix. We'll continue to post on our status page with any new information or updates.
Posted Dec 06, 2021 - 18:57 UTC

Investigating

We have received reports that users are unable to load their Account Settings. We are investigating this issue and will update this page when we have more information.
Posted Dec 06, 2021 - 18:47 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Console).