KMSAT - User Provisioning Latencies (US Only)
Incident Report for KnowBe4
Postmortem

From approximately 2:00 p.m. Monday, 04/22/2024, through 4:00 p.m. (UTC) Wednesday, 04/24/2024, the US instance of the KnowBe4 Security Awareness Training console experienced user provisioning sync delays.

This incident was caused by an inefficient backend process combined with unusually high user provisioning activity. Once we identified and improved the backend process, the KSAT console was able to return to normal performance by 4:00pm p.m. (UTC) on Wednesday, 04/24/2024.

To prevent this type of issue in the future, we have implemented additional alerts for when sync delays start to occur.

No data loss occurred as a result of this issue.

Posted May 30, 2024 - 19:43 UTC

Resolved
This incident has been resolved.
Posted Apr 26, 2024 - 20:51 UTC
Monitoring
We’ve implemented a fix for the user provisioning latencies and we’re monitoring the results to make sure no further issues occur.
Posted Apr 24, 2024 - 17:38 UTC
Identified
We've identified the cause of the latencies with user provisioning (including SCIM and ADI). and are working on implementing a fix. We'll continue to post on our status page with any new information or updates.
Posted Apr 24, 2024 - 14:40 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (User Provisioning).