KMSAT and PhishER - Direct Message Injection, PhishRIP, Webhook Issues
Incident Report for KnowBe4
Postmortem

On Tuesday, 8/17/2021, from approximately 1:09 p.m. until 8:06 p.m. (ET), users were experiencing issues with their KMSAT and PhishER consoles.

This incident was caused by an internal connection issue that caused several features to produce errors. All connections associated with these features were restored by 6:41p.m. (ET), however, some unprocessed items in KMSAT and PhishER were not fully processed until 8:06 p.m. (ET) at which time both consoles returned to normal performance.

To prevent this type of issue in the future, we have updated our internal systems to allow for faster recovery in the case of future connection issues.

For approximately 30 seconds at the start of this incident, some interactions with the disconnected features were not tracked. No data loss occurred as a result of this issue.

Posted Sep 23, 2021 - 14:00 UTC

Resolved
This incident has been resolved.
Posted Aug 18, 2021 - 12:06 UTC
Monitoring
A fix has been implemented as of 6:41 pm ET and we are monitoring the results.
Posted Aug 17, 2021 - 23:54 UTC
Identified
We've identified the cause of the issues and are working on implementing a fix. We'll continue to post on our status page with any new information or updates.
Posted Aug 17, 2021 - 18:44 UTC
Investigating
We have received reports that KMSAT and PhishER are experiencing issues. We are investigating these issues and will update this page when we have more information.
Posted Aug 17, 2021 - 17:26 UTC
This incident affected: Kevin Mitnick Security Awareness Training (KMSAT) (Console) and PhishER (PhishRIP, Webhooks).