Protect blank purchasing page on store.knowbe4.com

Incident Report for KnowBe4

Monitoring

We’ve implemented a fix for the online store and we’re monitoring the results to make sure no further issues occur.
Posted Jul 29, 2026 - 18:40 UTC

Investigating

We have received reports that customers are unable to purchase Protect licenses on store.knowbe4.com. We are investigating this issue and will update this page when we have more information.
Posted Jul 20, 2026 - 18:24 UTC

Monitoring

We’ve implemented a fix and we’re monitoring the results to make sure no further issues occur.
Posted Jul 17, 2026 - 18:55 UTC

Investigating

We are investigating users being unable to purchase Protect licenses on store.knowbe4.com. We will update this page when we have more information.
Posted Jul 17, 2026 - 13:18 UTC
This incident affects: KnowBe4 Website.