PhishER - Message Processing Delays

Incident Report for KnowBe4

Resolved

Our engineering team has implemented a fix for the issue that causing message processing delays in PhishER.
Posted Aug 26, 2026 - 19:51 UTC

Monitoring

Our engineering team has implemented a fix for the issue that causing message processing delays in PhishER, and we are monitoring the results.
Posted Aug 26, 2026 - 16:46 UTC

Investigating

We have identified an issue where users may experience delays in messages being processed, and our engineering team is looking into a fix.
Posted Aug 26, 2026 - 16:19 UTC
This incident affected: PhishER (Inbox).