KMSAT - Issues Loading Account Settings
Incident Report for KnowBe4
Postmortem

On Tuesday, 12/20/2022, from approximately 10:40 a.m. (ET) until 11:55 a.m. (ET), some users experienced issues loading their Account Settings page.

This incident was caused by a backend update that finished deploying before the accompanying frontend update. Once the frontend update finished deploying, KMSAT was able to return to normal performance by 11:55 a.m. (ET).

To prevent this type of issue in the future, the length of time to complete frontend and backend deployments will be determined prior to deployment. This information will be used to plan deployments so that both components finish at approximately the same time.

No data loss occurred as a result of this issue.

Posted Dec 28, 2022 - 15:47 UTC

Resolved
This incident has been resolved.
Posted Dec 20, 2022 - 19:18 UTC
Monitoring
We’ve implemented a fix for the issues some users were experiencing with their account settings and we’re monitoring the results to make sure no further issues occur.
Posted Dec 20, 2022 - 17:06 UTC
Identified
We've identified the cause of the issues some users are experiencing with their account settings and are working on implementing a fix. We'll continue to post on our status page with any new information or updates.
Posted Dec 20, 2022 - 16:26 UTC
This incident affected: Kevin Mitnick Security Awareness Training (KMSAT) (Console).