Defend and Prevent Admin Console Certificate Issue

Incident Report for KnowBe4

Postmortem

On Thursday, March 5, 2026, from approximately 02:20 until 03:10 (UTC), some customers experienced expired SSL certificate warnings when accessing their Defend and Prevent admin consoles.

This incident was caused by an expired certificate for an internal service. To resolve this issue, we deployed a new certificate and updated all affected instances. The Defend and Prevent consoles returned to normal performance by 03:10 (UTC).

To prevent this type of issue in the future, we are improving our certificate monitoring.

No data loss occurred as a result of this issue.

Posted Mar 16, 2026 - 15:50 UTC

Resolved

This incident has been resolved.
Posted Mar 05, 2026 - 12:44 UTC

Monitoring

We’ve implemented a fix for the certificate issue for Defend and Prevent admin consoles. A new certificate has been deployed and most traffic is restored while propagation completes across our global edge network.
Posted Mar 05, 2026 - 03:08 UTC

Identified

We've identified the cause of the certificate error when navigating to the Defend and Prevent admin consoles and are working on implementing a fix. We'll continue to post on our status page with any new information or updates.
Posted Mar 05, 2026 - 02:36 UTC
This incident affected: Prevent (Console), Defend (Console), and KnowBe4 Security Center.