KSAT - Unable to access training (All instances)

Incident Report for KnowBe4

Resolved

This incident has been resolved.
Posted Nov 14, 2025 - 23:48 UTC

Monitoring

We’ve implemented a fix and users should be able to login at this time. We will continue to monitor the results to make sure no further issues occur.
Posted Nov 14, 2025 - 17:10 UTC

Update

We have received additional reports that KSAT customer account creation is unavailable. We will continue to investigate this issue and will update this page when we have more information.
Posted Nov 14, 2025 - 16:58 UTC

Investigating

We have received reports that users are unable to access training. We are investigating this issue and will update this page when we have more information.
Posted Nov 14, 2025 - 16:41 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Console, Learner Experience (LX)).