KMSAT - Training Notification Placeholder Issue
Incident Report for KnowBe4
Postmortem

On Monday, 2/21/2022, from approximately 10:44 a.m. until 4:26 p.m. (ET), some users were seeing ID numbers instead of the titles of their training notifications.

This issue was caused by a code change that caused placeholders to use the notification's ID number instead of the notification's title. Once the placeholders were fixed, KMSAT returned to normal performance by 2/21/2022 at 4:26 p.m. (ET).

To prevent this type of issue in the future, we are adding additional testing and reviews to our workflow.

No data loss occurred as a result of this issue.

Posted Feb 24, 2022 - 16:38 UTC

Resolved
This issue has been resolved.
Posted Feb 22, 2022 - 00:27 UTC
Monitoring
We’ve implemented a fix for this issue and we’re monitoring the results to make sure no further issues occur.
Posted Feb 21, 2022 - 22:05 UTC
Update
We've discovered an issue where our training notifications are not displaying content titles. We are working to fix this issue and will update this page when we have more information.
Posted Feb 21, 2022 - 20:10 UTC
Identified
We've discovered an issue where our training notifications are not displaying the titles of customer-uploaded content. We are looking into this issue and will update this page when we have more information.
Posted Feb 21, 2022 - 19:28 UTC
This incident affected: Kevin Mitnick Security Awareness Training (KMSAT) (Training).